Answered Max_Thomax's question

Status
Not open for further replies.

MaxThomax

Mark
Joined
Jan 2, 2015
Messages
578
Reaction score
201
Question

In-Character Name:
Max_Thomax​

Service:
SA:MP​

Question:
downloaded gta san andreas lately. but when i try to open gta san andreas and play some good old samp it says GTA san andreas requires atleast directx version 9. and ok i unnanstand that but i got directx version 12 so it should fookin work shouldnt it?​
 



Thomas Stoglin

General Administrator
Junior Developer
Beta Tester
Lead Beta Tester
Old School 2014
Joined
Aug 15, 2015
Messages
1,244
Reaction score
148
Level
1
Awards
3

Christian Dodge

Senior Administrator
Junior Developer
Advisory Committee
Hippie Pipe Plumbers
Beta Tester
Joined
Jul 6, 2013
Messages
3,206
Reaction score
2,092
Try running SAMP in compatibility mode for Windows 98 / Windows Me
 

Christian Dodge

Senior Administrator
Junior Developer
Advisory Committee
Hippie Pipe Plumbers
Beta Tester
Joined
Jul 6, 2013
Messages
3,206
Reaction score
2,092
In your GTA:SA folder, you may see a file called d3d9.dll, this is the DirectX 9 file required, however, GTA:SA doesn't detect it. To fix this problem, rename it to d3d9_32.dll. This fixed the problem for me. I hope this helps anyone else who has this problem.

Source
 

MaxThomax

Mark
Joined
Jan 2, 2015
Messages
578
Reaction score
201
In your GTA:SA folder, you may see a file called d3d9.dll, this is the DirectX 9 file required, however, GTA:SA doesn't detect it. To fix this problem, rename it to d3d9_32.dll. This fixed the problem for me. I hope this helps anyone else who has this problem.

Source
cant find a d3d9.dll file, means that is de problem eh?
 
Status
Not open for further replies.